Using Adobe Photoshop and Adobe Illustrator

Most of the image editing operations researchers will need to perform can be completed using freely available software like the GNU Image Manipulation Program, OpenOffice Draw, and ImageJ. Please refer to the the PedOnc Figure Preparation and Image Editing Workshop here for detailed information on how to obtain and use these tools and for an introduction to concepts that are important for all image editing.

This document is designed to supplement the Figure Preparation and Image Editing Workshop by describing how to complete the operations performed in the workshop with the GNU Image Manipulation Program using Adobe Photoshop. It also describes how to complete the operations performed in the workshop with OpenOffice Draw using Adobe Illustrator.

Exchanging Data

The Adobe Photoshop and Illustrator applications are popular, and collaborators may exchange figures in Adobe's proprietary file types. Occasionally, medical journals or grant applications may also require that files be submitted in one of Adobe's file types.

In cases where data needs to be exchanged between programs, there are some file types that will work in multiple programs.

To move a single-layer 8-bit per channel RGB image from Photoshop to GIMP, save to PNG.

To move a single-layer 8-bit per channel RGB image from GIMP to Photoshop, export to PNG.

To move a multi-layer RGB image from Photoshop to GIMP, save to PSD.

To move a multi-layer RGB image from GIMP to Photoshop, export to PSD.

To move paths from Photoshop to GIMP, save to PSD.

To move paths from GIMP to Photoshop, export paths to SVG and use Illustrator to convert them (this does not always work properly as Photoshop has difficulty importing paths).

To move vector and bitmap data from Illustrator to OpenOffice Draw, save to SVG.

To move vector and bitmap data from OpenOffice Draw to Illustrator, export as a PDF with high quality settings or export to SVG.

To move vector and bitmap data from OpenOffice Draw to Microsoft Word, PowerPoint, or Excel, copy data from OpenOffice Draw, paste into a new empty OpenOffice Writer document, then save as a Microsoft Word 97/2000/XP (.doc) file.

In most cases, if data must be moved into or out of the Adobe programs, it should be possible to use a portable file type like PNG for bitmap or SVG for vector/vector and bitmap to move data. Researchers can use PedOnc Core Imaging workstations with Adobe licenses as first/last steps when exchanging files that must be in Photoshop PSD or Adobe AI format.

Using Photoshop

To reset the dialogs in Adobe Photoshop to their default locations, open Photoshop and go to the Window menu, then select Workspace and Reset Essentials. Many tools in GIMP have an equivalent in Photoshop. Photoshop groups and hides some tools; to reveal tools that are hidden in the Tools dialog in Photoshop, click and hold on tool icons with small triangles in their lower-right corners to expand the list of tools grouped under that icon. For example, the Gradient, Paint Bucket, and 3D Material Drop tools are all grouped under the same icon in Photoshop.

Photoshop combines saving and exporting image data into a single window. In Photoshop, go to the File menu and select Save As, then save as either a PSD file (which is Photoshop's equivalent of GIMP's XCF file type) to save all image data, or select another file type (e.g., PNG) from the format pulldown menu to export image data to another file type. Please note that while GIMP makes a clear distinction between saving a file (retaining all image data) and exporting a file (which can alter image data), Photoshop uses the same Save As window to perform these different operations. Be sure to use the correct file format to preserve image data.

Tool Options in Photoshop typically appear at the top of the Photoshop window when a tool is selected. In addition to the options presented at the top of the window, Photoshop relies on modifier keys to access certain tool options. Common modifier keys in Photoshop are Control, Shift, Alt, and Space.

For example, with the Rectangular Marquee (selection) tool, move the mouse cursor over the image canvas and click and hold the mouse button, then begin dragging to draw a selection rectangle. With the mouse button still held down, hold the Space bar on the keyboard and continue dragging with the mouse: the existing selection rectangle moves. Release the Space bar and continue dragging with the mouse to resize the selection rectangle from its new position. Release the mouse button to complete creating a selection area.

To add to the existing selection area, with the Rectangular Marquee tool still selected, hold down the Shift key and click and drag with the mouse over the image to create another rectangular selection area. This selection area will be added to the area already selected. The Space bar modifier can be used to move this area while it is still being formed until the mouse button is released. The Alt key can be used similarly to the Shift key when using the selection tools to subtract from the selection area. Experiment with various combinations of tools and modifier keys to discover other tool options.

One area where Photoshop differs from GIMP is that it stores the history of operations performed on active image data as steps. Photoshop only allows users to Undo the last step by going to the Edit menu and selecting Undo. To undo previous steps, navigate to the Edit menu and select Step Backward.

Photoshop also consolidates resampling an image and changing an image's print size in a single window. To change an image's print size without altering image data, go to the Image menu in Photoshop, then select Image Size. In the window that appears, to change the image's print size and avoid altering the image data, uncheck Resample, then modify the image's print size as desired and click OK.

To resample an image in Photoshop, go to the Image menu in Photoshop, then select Image Size. In the window that appears, check Resample, then adjust the image dimensions as needed and click OK. Please note that this will modify the image's data.

To access Quick Mask Mode in Photoshop, click the rectangular icon that contains a broken circle directly beneath the Foreground and Background color swatches in the Tools dialog.

Using Illustrator

In Adobe Illustrator, selecting colors is performed similarly to in GIMP and Photoshop. At the bottom of the Tools dialog, there are swatches for the Stroke Color (the lower-right frame shaped swatch) and Fill Color (the upper-left square swatch). Double-click on either of these to select a fill or stroke color.

When in the main Illustrator window, single-click on either the fill or the stroke swatch to select it, then single-click on one of the 3 square swatches immediately below the Fill and Stroke swatches to set the Fill or Stroke (whichever is selected) to a solid color, a gradient, or a nothing (the right-most white box with a red slash through it).

Illustrator has two selection tools. The dark arrow icon at the top of the Tools dialog is the standard Selection Tool, which works similarly to the selection tool in OpenOffice Draw. This selection tool lets you select and move entire objects or groups of objects.

Immediately below the standard Selection Tool is a lighter arrow icon which is the Direct Selection Tool. The Direct Selection Tool works like Points mode in OpenOffice Draw and allow selection and modification of parts of shapes.

To convert a complex object, like text, into a shape (as Convert to Contour does in OpenOffice Draw), select an object in Illustrator with the Selection Tool, then go to the Object menu and select Expand. In the window that appears, configure options to expand the stroke and fill as desired, then click OK.

To create Bezier curves in Illustrator, use the Pen Tool. When drawing with the Pen Tool, click and drag when placing a control point to modify the tangent line for the control point (just as in OpenOffice Draw). Use the Alt key as a modifier when modifying a tangent to break the continuity of the curve (like creating a Corner Point in OpenOffice Draw).

To set the stroke width, navigate to the Window menu in Illustrator and select Stroke to display the Stroke dialog. With an object selected, change the numeric value in the Weight field of the Stroke dialog to alter the stroke width. Note that the selected object must have the stroke set to visible (not None).

Summary

After completing the PedOnc Figure Preparation and Image Editing Workshop and experimenting with the tools and techniques presented above, it should be possible to replicate the operations performed with GIMP and OpenOffice Draw in the workshop using Adobe Photoshop and Adobe Illustrator. There are many valuable resources on the web with tips and instructions for image editing using all of these programs, so please seek out more information online and share and compare image editing techniques with colleagues.